3rd Party Cloudfare Service Disruption
Resolved
This incident has been resolved.
Posted Nov 18, 2025 - 11:07 EST
Monitoring
Cloudfare reports a fix has been implemented and have resolved their incident. We will be continuing to monitor to ensure all services are back to normal.
Posted Nov 18, 2025 - 09:47 EST
Identified
We are aware of a major, widespread outage affecting our core Content Delivery Network (CDN), Cloudflare. Cloudflare is currently experiencing a "Global Network Issue," which is impacting many services across the internet, including Greenlight Guru Systems.
Posted Nov 18, 2025 - 08:56 EST
This incident affected: Ultralight - QMS (Ultralight - US, Ultralight - EU).