Service Disruption - Quality Processes

Incident Report for Greenlight Guru Services

Postmortem

Incident Summary

On October 23rd, customers experienced failures when viewing embedded PDFs within the Quality Processes workspace between approximately 14:00 UTC and 14:18 UTC.

Impact

Affected: Users attempting to view embedded PDFs within the Quality Processes workspace
Symptoms: Users attempting to view these PDF’s received a “refuse to connect error”
Duration: ~18 minutes

Root Cause

A recent security update to prevent unauthorized embeddings caused some legitimate embeddings to be unable to load.

Resolution

At 14:14 UTC, the security configuration was corrected to allow legitimate embedded loads in the pre-production environment and validated by the team. At 14:18 UTC, the fix was deployed to all production environments, fully restoring service.

Next Steps / Prevention

We will:

  • Implement automated testing to cover loading of embedded PDF’s.

Status

This incident is resolved.

Posted Oct 27, 2025 - 14:49 EDT

Resolved

This incident has been resolved.

All impacted services are functioning normally.

Thank you for your patience and understanding.
Posted Oct 23, 2025 - 10:38 EDT

Monitoring

A fix has been implemented, and we are closely monitoring the system to ensure full stability.

Please reach out to support@greenlight.guru if you continue experiencing issues.
Posted Oct 23, 2025 - 10:32 EDT

Investigating

We are currently investigating a disruption affecting the quality process workspace.
Posted Oct 23, 2025 - 10:26 EDT
This incident affected: Greenlight - QMS (Greenlight - US, Greenlight - EU, Greenlight - AUS, Greenlight - Singapore).